Zero knowledge about Ruby, Rails or Linux required.